Card Operations Partial Outage
Incident Report for Unit
Resolved
This incident has been resolved.
Posted Jun 18, 2021 - 08:51 UTC
Identified
The following card operations are not available: create, freeze, unfreeze, or report lost or stolen.
We identified a network problem and working on a fix.
Posted Jun 18, 2021 - 04:30 UTC
This incident affected: Unit.