Card Usage
Incident Report for Unit
Resolved
We investigated a high rate of card declines coming from Visa. This is resolved.
Posted Nov 12, 2024 - 18:35 UTC
Investigating
We are currently investigating this issue.
Posted Nov 12, 2024 - 18:27 UTC
This incident affected: API (Cards).