Delay in Business Applications Processing
Incident Report for Unit
Resolved
The incident has been resolved. Our team is now rerunning the applications that have been delayed.
Posted Mar 24, 2023 - 17:01 UTC
Identified
Our automated verification vendor is experiencing an issue with business information verification. You might experience a temporary delay in the processing of business applications. We are working with the vendor to resolve the issue as soon as possible.
Posted Mar 24, 2023 - 13:45 UTC
This incident affected: API (Onboarding).