Payments Degraded Performance
Incident Report for Unit
Resolved
This incident has been resolved.
Posted May 18, 2024 - 17:10 UTC
Investigating
We are currently investigating this issue with payment creation.
Posted May 18, 2024 - 16:45 UTC
This incident affected: API (Payments).