Elevated error rates and response times
Incident Report for Unit
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 04:15 UTC
Investigating
We are currently investigating this issue.
Posted Nov 19, 2021 - 03:30 UTC
This incident affected: Unit.