Received ACH Connectivity Issue w/ Blue Ridge Bank

Incident Report for Unit

Resolved

This issue was resolved.
Posted Jun 26, 2023 - 19:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 26, 2023 - 19:43 UTC

Investigating

We are aware of an ACH connectivity issue with Blue Ridge Bank and a third party vendor causing a delay with received ACH payments. We are working to resolve the issue.
Posted Jun 26, 2023 - 15:46 UTC
This incident affected: API (Payments).