Payment Issues
Incident Report for Unit
Resolved
This incident has been resolved.
Posted Feb 24, 2023 - 21:39 UTC
Investigating
Payments may fail. If you experience a failure, please attempt the payment again.
Posted Feb 24, 2023 - 19:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2023 - 18:27 UTC
This incident affected: API (Payments).