Degraded Sandbox Performance

Incident Report for Unit

Resolved

This incident has been resolved.
Posted May 06, 2026 - 23:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2026 - 23:02 UTC

Investigating

We are experiencing degraded performance in sandbox with intermittent failures, affecting the Dashboard and API response times. Investigation is in progress.
Posted May 06, 2026 - 22:36 UTC
This incident affected: Sandbox (Onboarding, Payments, Cards, Core, Webhooks) and Dashboard.